Scheduled Performance Maintenance
Incident Report for Plixi
Resolved
This incident has been resolved.
Posted Jun 10, 2022 - 13:49 UTC
Identified
We are currently implementing v3.5.0 of the Growth Engine. The update includes significant performance improvements, new account modules & optimizations, as well as additional audience targeting options.

Performance will be degraded until the updated is fully completed.
Posted Jun 10, 2022 - 01:00 UTC
This incident affected: Growth Engine, Growth API (api.plixi.com), and Analytics & Reports.